For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Real-time transactions experiencing slowness
Incident Report for Optum Solutions
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 09:52 EDT
Monitoring
Optum has implemented solution and is monitoring to ensure functionality.

Next update will be at 10:15 or when the situation changes.
Posted Apr 15, 2024 - 09:39 EDT
Identified
Real-time transactions are experiencing slowness. Optum is working toward a solution to this issue.

Next update will be at 9:15 a.m. ET or when significant progress has been made.
Posted Apr 15, 2024 - 09:03 EDT
This incident affected: Medical Network Services (eligibility, enrollment and clearinghouse) (Batch claims transmission, Real-time eligibility transactions).