For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Claims processing issue
Incident Report for Optum Solutions
Resolved
This issue has been resolved.
Posted Apr 18, 2024 - 11:59 EDT
Update
We continue to monitor this issue.

Next update will be when the issue has been resolved.
Posted Apr 18, 2024 - 09:51 EDT
Monitoring
This message is intended for Exchange and Assurance Reimbursement Management customers.

We are currently experiencing issues receiving claims from customers that use our batch processing. A fix has been implemented and our team is monitoring to ensure operability.

INC0550651
Posted Apr 18, 2024 - 08:58 EDT
This incident affected: Medical Network Services (eligibility, enrollment and clearinghouse) (Batch claims transmission) and Revenue Cycle Management (Assurance Reimbursement Management).