For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Clinical Network experiencing issues
Incident Report for Optum Solutions
Resolved
This incident has been resolved.
Posted May 05, 2024 - 13:35 EDT
Update
We are continuing to monitor for any further issues. Next update will be provided at 2:00 p.m. ET or earlier upon significant progress.
Posted May 05, 2024 - 12:06 EDT
Update
We are continuing to monitor the impact of this incident. Next update will be provided at 12:00 p.m. ET or earlier upon significant progress.
Posted May 05, 2024 - 10:02 EDT
Update
We are continuing to monitor for further issues. Next update will be provided at 10:00 a.m. ET or earlier upon significant progress.
Posted May 05, 2024 - 09:02 EDT
Update
Optum continues to monitor to ensure all applications are functioning.

Next update will be at 9 a.m. or when this issue is resolved.
Posted May 05, 2024 - 08:13 EDT
Monitoring
Optum has identified a solution and is monitoring to ensure functionality.

Next update will be at 8 a.m. ET or when the issue has been resolved.
Posted May 05, 2024 - 07:31 EDT
Identified
Optum has identified the issue and is working toward a solution.

Next update will be at 7:30 or when significant progress has been made.
Posted May 05, 2024 - 07:11 EDT
Investigating
Clinical Network is experiencing issues with delivery of lab results and orders.

Optum is working towards identifying this issue. Next update will be at 7:30 a.m. ET or when significant progress has been made.

INC 0556738
Posted May 05, 2024 - 07:02 EDT
This incident affected: Clinical Network (Clinical Exchange Channel Partners including ePrescribe and Orders & Results, Clinical Exchange Labs and Hospitals).