For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Real-time and batch claims processing issue
Incident Report for Optum Solutions
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 07:23 EDT
Update
We are continuing to investigate this issue. Next update will be provided at 8:00 a.m. ET or upon significant progress.
Posted Apr 19, 2024 - 07:01 EDT
Update
This incident is ongoing and we are continuing to investigate the issue. An update will be provided at 7:00 a.m. ET or earlier upon significant progress.
Posted Apr 19, 2024 - 06:00 EDT
Investigating
Real-time and batch claims transactions are currently failing or processing with intermittent issues. We are currently working towards a solution. An update will be provided at 6:00 a.m. ET or earlier upon significant progress.

INC 0551373
Posted Apr 19, 2024 - 05:03 EDT
This incident affected: Medical Network Services (eligibility, enrollment and clearinghouse) (Batch claims transmission, Real-time eligibility transactions) and Revenue Cycle Management (Assurance Reimbursement Management).