For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Communications Complete is not performing as expected.
Incident Report for Optum Solutions
Resolved
We are eager to inform you that this issue is resolved.
Posted May 03, 2024 - 14:55 EDT
Identified
This message is intended for Communications Complete - Payers.
Some customers are currently experiencing issues sending payment files. Optum is triaging the issue and will provide further updates as they are available. We apologies for the inconvenience this situation has cause you.

REF# INC0056395
Posted May 03, 2024 - 12:31 EDT
This incident affected: Payer Communications and Payment Services (Communications Complete - Payer).